KnowledgeBoat Logo

Computer Applications

Write a program to accept a string. Convert the string into upper case letters. Count and output the number of double letter sequences that exist in the string.
Sample Input: "SHE WAS FEEDING THE LITTLE RABBIT WITH AN APPLE"
Sample Output: 4

Java

Java String Handling

ICSE

173 Likes

Answer

import java.util.Scanner;

public class KboatLetterSeq
{
    public static void main(String args[]) {
        Scanner in = new Scanner(System.in);
        System.out.print("Enter string: ");
        String s = in.nextLine();
        String str = s.toUpperCase();
        int count = 0;
        int len = str.length();
        
        for (int i = 0; i < len - 1; i++) {
            if (str.charAt(i) == str.charAt(i + 1))
                count++;
        }
        
        System.out.println("Double Letter Sequence Count = " + count);
        
    }
}

Output

BlueJ output of Write a program to accept a string. Convert the string into upper case letters. Count and output the number of double letter sequences that exist in the string. Sample Input: "SHE WAS FEEDING THE LITTLE RABBIT WITH AN APPLE" Sample Output: 4

Answered By

68 Likes


Related Questions