KnowledgeBoat Logo

Computer Applications

Write a program to input a number and perform the following tasks:

(a) to check whether it is a prime number or not

(b) to reverse the number

If the number as well as the reverse is also 'Prime' then display 'Twisted Prime' otherwise 'Not a twisted Prime'.

Sample Input: 167
Sample Output: 167 and 761 both are prime.
It is a 'Twisted Prime'.

Java

Java Nested for Loops

ICSE

43 Likes

Answer

import java.util.Scanner;

public class KboatTwistedPrime
{
    public static void main(String args[]) {
        Scanner in = new Scanner(System.in);
        System.out.print("Enter number: ");
        int num = in.nextInt();

        if (num == 1) {
            System.out.println(num + " is not a twisted prime number");
        }
        else {
            boolean isPrime = true;
            for (int i = 2; i <= num / 2; i++) {
                if (num % i == 0) {
                    isPrime = false;
                    break;
                }
            }
            
            if (isPrime) {
                
                int t = num;
                int revNum = 0;
                
                while (t != 0) {
                    int digit = t % 10;
                    t /= 10;
                    revNum = revNum * 10 + digit;
                }
                
                for (int i = 2; i <= revNum / 2; i++) {
                    if (revNum % i == 0) {
                        isPrime = false;
                        break;
                    }
                }
            }
            
            if (isPrime)
                    System.out.println(num + " is a twisted prime number");
                else
                    System.out.println(num + " is not a twisted prime number");
            }

    }
}

Output

BlueJ output of Write a program to input a number and perform the following tasks: (a) to check whether it is a prime number or not (b) to reverse the number If the number as well as the reverse is also 'Prime' then display 'Twisted Prime' otherwise 'Not a twisted Prime'. Sample Input: 167 Sample Output: 167 and 761 both are prime. It is a 'Twisted Prime'.

Answered By

12 Likes


Related Questions